
 

New features of CadnaA 2022 MR2 

New features of CadnaA 2022 and 2022 MR1 can be found here.  

Configuration Methods 

• New Calculation method “HJ 2.4 (2021)” (China) for noise types 

o Industry noise 

o Road noise 

o Railway noise 

• HJ 2.4 (2009), Road noise: Speed range of JTG B03 is now also applied for the 

calculation of Leq (formula A.12 of HJ 2.4 (2009)).  

• SonRoad18: Consideration of foliage according to ISO 9613-2, annex A implemented. 

• CNOSSOS-EU (Directives 2015/996 and 2021/1226) or country-specific 

implementations: Reduced initialization times for projects without industry sources.  

Features 

• Object tables, Change Column: New option “Starting Number” for definition of the 

number, at which the numbering with # should start.  

• New function "Zoom to Object" in the context menu for each object. The 2D view is 

adjusted so that the object is displayed completely. 

• Consistency check warnings are now saved as local text block CALC_WARN 

• Object-Scan Preset "EU 2021/1226 | People in level classes (Median)" modified to 

also consider buildings with multiple storeys. If a building has only one storey, there 

is no change in the calculation results (typical case with receivers in 4m height). 

• PlotDesigner: “Display units” (defined in the Options menu) are now also used for 

labelling of the plan cell  

• Symbol, Scale bar: Display units (defined in Options Menu) are now considered 

• Aircraft Noise: Traffic-Count Calculator | Normalize Aircraft Classes: If the ID of an 

aircraft group ends with "-S" or "-L", it will be truncated. (Feature already included 

since 2022 MR1) 

• CadnaA Silent Setup: Added command line option /skipwebview=true to skip 

WebView2 installation.  

• Configuration of Calculations | Tab Standards | Template: For all CNOSSOS-EU 

related templates (starting with 2015/996 or 2021/1226), parameter Modify NPD 

Curves for calculation of aircraft noise is now checked to be activated.  

 

Bug Fixes 

• Object-Scan Preset "EU 2021/1226 | Noisiest grid point in/near building | Step 2" 

corrected. Formula for evaluation parameter 2/3/4 always used the maximum value 

of LP1 (instead of LP2/3/4) as input. 

• Calculation method CNOSSOS-EU (Directives 2015/996 and 2021/1226) or country-

specific implementations, railway object: For the calculation of the vertical directivity, 

the angle of direct line of sight from source to receiver is now used. Before, in case of 



 

an obstacle in the propagation path, the angle was calculated from the source to the 

upper edge of the obstacle. 

• Railway object: Sum level was not shown for calculation methods with input of sound 

power level as 1/3 octaves (e.g. for CNOSSOS-EU).  

• Railway object, attribute MIND_I: Prevent negative values, which could occur after 

import or user input. 

• Fixed error “ARB_create_context” when opening 3D view 

• Calculation Method Schall03 (1990), railway object: Bugfix regarding selection “Type 

of track”. Correction was not applied correctly in the calculation.  

• Road object: When using the function self-screening in combination with road width 

per polygon point, the width of the self-screening was not considered correctly. 

• Calculation Method TNM 2.5: Maximum number of edges considered in the 

screening calculation increased. Potential change of calculation results with larger 

calculation models. 

• Aircraft noise: When specifying / importing an aircraft group with suffix "-S" or "-L", 

the aircraft group is now correctly assigned. Example: Aircraft group with ID 

"S3_M070_TU_NX-S" is assigned to "S3_M070_TU_NX". 

• Fixed possible crash when using the function “Optimize walls” 

• Fixed incorrect display of façade bitmaps  

• Bugfix for arithmetic expressions / conditions: In some cases, the expression was not  

• evaluated correctly.  

Attributes, Variables and Keywords 

• Object crossing: Attribute TYPE for setting “Crossing is Roundabout” added 

• Railway object: Access to list “number of trains” via attributes CXX_TYP/ND/NE/NN/ 

V/L/P/DFZ/NAXLE extended up to C99 (instead of maximum C13 before). 

• Aircraft noise, Aircraft Group: Attribute ACFTXXT/E/N extended up to ACFT99T/E/N 

(before max. 50)  



 

New Features of CadnaA Version 2022 and 2022 MR1 

Configuration of Calculation 

• Rename Tab „Country“ in Tab „Standards“. In Tab Standards: 

o Removal of the country selection. The calculation methods for the noise types 

industry, road and railroad are now always selected individually (analog to 

previous country selection „user defined“)  

o „Parameter Check“ becomes „Template“, see separate section later in this 

document. 

• New calculation methods according to CNOSSOS-EU, see separate section later in this 

document. 

• Calculation method CNOSSOS-EU: Setting „Calculation acc. to“ to define the EU-

version or a specific national implementation can now be set separately for each 

noise type in the tabs industry, road and railroad (previously: one setting for all 

beforementioned noise types). 

• Railroad Tab (CNOSSOS-EU): New input parameter number of „Train-Barrier-

Interactions“, default value is 0.  

• Tab Road (CNOSSOS-EU): Button „Vehicle classes“ extended to selection menu. This 

now shows default vehicle classes defined in the internal default library and user-

defined entries of the local library.  

• Tab Evaluation Parameters: When using the Evaluation Parameter „DIN4109tot“ or 

„f(x)=DIN4109totd/n“ the noise type industry is now always considered with target 

value Lde, independent of the setting of other Evaluation Parameter (previously: Ld). 

• Tab Evaluation Parameters: When using the Evaluation Parameter „DIN4109tot“ or 

„f(x)=DIN4109totd/n“ the case distinction regular case/special case for the noise type 

Industry is now also carried out for the calculation in the grid (previously only for 

Receivers and Building Evaluations).  

• Tab Ground Absorption: Default value for resolution at map of ground absorption = 

1m (previously 2m) 

• Calculation method SonRoad18: Implementation of further developments and 

supplements published in 2021 1 

• New template for the definition of calculation parameters according to SonRoad18 

(2021) with propagation according to ISO 9613-2 considering 17534-3 (test cases) 

• Road object (SonRoad18): New import from SonRoad18 webtool 

• Road types (SonRoad18): Further vehicle categories added 

Building Noise Map 

• Setting „Lower Rcvr max 20cm below eave“ additionally considers that no receivers 

with a relative height < 2.0 m above ground are generated (according to BUB 2021). 

 
1 Calculation Method: sonROAD18 – Berechnungsmodell für Straßenlärm – Weiterentwicklungen und 
Ergänzungen, Empa-Nr. 5214.019298, 5214.023513, 2020-11-30 



 

Calculation | Configuration | Calculation Methods (CNOSSOS-EU) 

The following calculation methods have been introduced into CadnaA to implement the 

European Directives 2015/996 and 2021/1226 and their national implementations. After 

selecting "CNOSSOS-EU" in the "Standards" Tab, the European or national implementations 

can be selected for each noise type Tab: 

• Industry: 

„Calculation acc. to“ previously Comment 

2015/996 EU CNOSSOS-EU 
Implementation of additional 
specifications from ISO TR 17534-4, 
Version 20202 

2021/1226 EU - 
Implementation of the EU Directive 
2021/1226 

 

• Road 

„Calculation acc. to“ previously Comment 

2015/996 EU CNOSSOS-EU Implementation of additional specifications 
from ISO TR 17534-4, Version 2020Fehler! 
Textmarke nicht definiert. 

2015/996 DE (BUB 2018) CNOSSOS-DE 

2015/996 AT (RVS 2019) CNOSSOS-AT 

2021/1226 EU - 
Implementation of the EU Directive 
2021/1226 

2021/1226 DE (BUB 2021) - Implementation of the national 
interpretations of EU Directive 2021/1226 
for Germany and Austria. 

2021/1226 AT (RVS 2021) - 

 

• Railroad 

„Calculation acc. to“ previously Comment 

2015/996 EU CNOSSOS-EU 
Implementation of additional specifications 
from ISO TR 17534-4, Version 20201 

2015/996 DE (BUB 2018) CNOSSOS-DE 

2015/996 AT (RVE 2019) CNOSSOS-AT 

2015/996 FR (SNCF 2021) - 
Implementation of the national 
interpretations of EU Directive 2015/996 for 
France. 

2021/1226 EU - Implementation of EU Directive 2021/1226 

2021/1226 DE (BUB 2021) - 
Implementation of the national 
interpretations of EU Directive 2021/1226 
for Germany, Austria, Belgium and France. 

2021/1226 AT(RVE 2022) - 

2021/1226 BE (Infrab. 2022) - 

2021/1226 FR (SNCF 2022) - 

 
2 Existing projects saved with CadnaA 2021 MR2 (or earlier) are displayed with the addition "w/o 17534" in the 
calculation configuration when opened with CadnaA 2022. For new CadnaA files this selection option is no 
longer available. 
 



 

New Feature „Templates“ 

• CadnaA-internally defined Templates for calculation according to a specific standard, 

regulation, guideline or method, which takes into account settings of the 

Configuration of Calculation, Building Noise Map, individual Objects and Areas of 

Designated Use. A template can be selected at the following places in CadnaA:   

o Configuration of Calculation, Tab „Standards“: When a Template is selected, 

the current settings are compared with the Template and deviations are 

displayed. With a click on OK all settings of the Template are taken over into 

the project. 

o For new projects in the File menu → New (Template). A new CadnaA model 

can thus be initialized with a basic setting. The selected template is saved in 

the calculation configuration, "Standards" Tab. 

• In the menu „New (Template)“ additional user defined CadnaA files can be used as 

templates by placing them in the installation directory in the subdirectory 

templates/new. 

This path can be customized via an entry in the INI-file (section [Main], Variable 

NewTemplateDir= „C:\example“). 

CadnaA-Objects 

• Railroad (CNOSSOS-EU): representation of emission now in 1/3-Oktave Band 

Spectrum (previously in octaves) 

• Bitmap: The feature „Choose region in browser“ upon import from Google Maps is 

now based on the Microsoft Edge browser which is usually available by default on 

Windows systems. 

ObjectScan 

• New default entry „2021/1226, People in level classes (Median)“ for evaluation 

according to EU Directive 2021/1226 or a national interpretation. 

• New default entry „2021/1226, Noisiest grid point in/near building“ and „2021/1226, 

Quietest grid point near building“ for determining the loudest/quietest immission 

level in the grid following the procedure of the test tasks for BEB 2021. Detailed 

instructions can be found in the CadnaA Reference Manual. 

• New default entry „2020/367“: Calculation according to EU Directive 2020/367 on 

the assessment of harmful effects of environmental noise. Calculation of risk 

ischaemic heart disease (IHD), highly annoyed people (HA) or highly sleep disturbed 

people (HSD). The calculation procedure is performed in conjunction with the 

function in the Calculation | Multiple Source Effect menu. For more information, 

please refer to our reference manual. 

• Default entries reorganized with hierarchical menu. User-defined entries can also be 

stored hierarchically by specifying "\" in the name.  

• New Option „Grid Point as Rectangle“: When checking whether a grid point lies 

within an area/inside a window, the associated rectangle is used instead of the x/y 

position of the point. If rectangle and area/window intersect, the grid point is taken 

into account. 



 

• New Attributes for „Formula for Summation“ LPx_MIN8 and LPx_MAX8. With the 

help of these attributes the minimum/maximum value of the 8 neighboring grid 

points (horiz., vert., diag.) can be determined.  This function is used in connection 

with the preset „2021/1226, Quietest grid point near building “.  

Libraries 

• New library „Vehicle Classes“ for the definition of different emission parameters 

according to CNOSSOS-EU or a country-specific implementation. 

• Library „Road Surfaces“ for CNOSSOS-EU extended by the input of speed ranges. In 

addition, it can be defined whether a road surface is valid for 2015/996 and/or 

2021/1226.  

• Library-Manager: New option „Keep both“. When importing to the local / global 

library, if the ID between existing library entry/library entry to be imported is the 

same, both are kept. 

Attributes, Variables und Keywords 

• For calculation method CNOSSOS-EU, new keywords for setting „Calcluation acc. to“ 

for each noise type tab.  

o Tab Industry = CNS_ICNTRIN,  

o Tab Road = CNS_ICNTRRD,  

o Tab Railroad = CNS_ICNTRRL,  

o Tab Aircraft = FLG_ICNTRY.  

• The previous keyword ICNTRY is still valid for the setting in the Industry Tab.  

• For calculation method CNOSSOS-EU, new keyword CNS_VEHCLS for the selected 

vehicle class in the Tab „Road“. 

• For calculation method CNOSSOS-EU, new keywords CNS_VMAX_XX with XX 

indicating the vehicle class (1, 2, 3, 4A, 4B) for referencing the vehicle class-

dependent maximum speed in the "Road" Tab.  

• Keywords #(ImmValName, param1, param2) and #(ImmValUnit, param1, param2) 

extended. The name of a plot cell (in the plot designer) can now be specified as 

param2. Then evaluation parameter/unit of the plan cell is displayed. 

• Object Railroad: New Attributes:  

o RAILROUGHI: Rail roughness as Integer 

o RAILROUGH: Rail roughness as String 

o DBR_STR: Select Bridge as String 

o RAI: Select curve radius as Integer 

o SQUEAL_MEAS: Measure against curve squeal (1/0) 



 

Further Innovations 

• Menu Options |Appearance: Double click on object type in list activates / deactivates 

the display of this object type 

• Menu Tables |Variant: Double click on list object activates / deactivates this variant 

• New Lua-function cna.activate_protocol() to activate/deactivate the protocol and 

cna.get/set_weighting() read/write the weighting under Options → Miscellaneous 

• Keyword #(SetObjAtt, ...) now also accepts GLK_OPT as parameter 1 to set 

parameters in the Options | Building Noise Map menu. 

• New attributes for accessing parameters of the Configuration of Calculations:  

o IND_OCT_3: Calculation in 1/3 octaves, see Tab Industry, e.g. with ISO 9613-2 

o SONR_VERS: SonRoad18 version, see Tab Road 

Bug Fixes 

• Optimization of the function „map of ground absorption“ in the menu Calculation| 

Configuration | Tab Ground Absorption. In certain cases, the ground absorption areas 

could be incorrectly taken into account. 

• An error has been corrected when importing directivities in XHN format, where the 

values were incorrectly interpreted as level correction instead of attenuation. It is 

recommended to re-import affected directives. 

• Fixed incorrect import of barriers from *.prj-Dateien (Mithra). 

• NMPB08, CNOSSOS-EU: Bug fix when using the meteorology correction in 

combination with industrial sources and input as A-level. In this combination it could 

occur that the day level was used for all reference times. 

• Road (SonRoad18): Access to the global library via folder icon fixed 

• Import: Bug fix when importing a CityGML file. When reaching 100% CadnaA did not 

react for some seconds. 

• ObjectScan: Activation state of the objects was not considered for all presets.  


